Bravo List
Register
Go Back   > Bravo List > Source Code > Trackers > Gazelle
Reply
  #11  
Old 18-01-10, 23:34
mrs's Avatar
mrs mrs is offline
Senior Member
 
Join Date: Jul 2008
P2P
Posts: 17
Question
Quote:
6. Getting tracker up and running

[code]$ cd /site/
$ tar zxfv xbtt.tar.gz
$ cd xbtt/build/xbtt
$ ./autogen.sh
$ make

i have an error when i try to run ./autogen.sh
..........
Code:
checking signal.h usability... yes
checking signal.h presence... yes
checking for signal.h... yes
checking for unistd.h... (cached) yes
checking whether byte ordering is bigendian... no
checking for short... yes
checking size of short... configure: error: cannot compute sizeof (short), 77
See `config.log' for more details.

I am using a centos 5.4 vmware image with latest updates and lxadmin control panel.

Please help me

Regards
Reply With Quote
  #12  
Old 18-01-10, 23:35
movizdb's Avatar
movizdb movizdb is offline
Senior Member
 
Join Date: Sep 2008
France
Posts: 142
Default
Maybe it's because of the lxadmin Remove LXadmin then retry ;)
Reply With Quote
  #13  
Old 18-01-10, 23:37
mrs's Avatar
mrs mrs is offline
Senior Member
 
Join Date: Jul 2008
P2P
Posts: 17
Default
Quote:
Originally Posted by movizdb View Post
Maybe it's because of the lxadmin Remove LXadmin then retry ;)
But i need lxadmin for hosting :D
Reply With Quote
  #14  
Old 18-01-10, 23:46
Phogo's Avatar
Phogo Phogo is offline
Super MOD
 
Join Date: Jan 2008
United Kingdom
Posts: 895
Default
Quote:
Originally Posted by marius View Post
i have an error when i try to run ./autogen.sh
..........
Code:
checking signal.h usability... yes
checking signal.h presence... yes
checking for signal.h... yes
checking for unistd.h... (cached) yes
checking whether byte ordering is bigendian... no
checking for short... yes
checking size of short... configure: error: cannot compute sizeof (short), 77
See `config.log' for more details.
I am using a centos 5.4 vmware image with latest updates and lxadmin control panel.

Please help me

Regards
Post your config.log
Reply With Quote
  #15  
Old 18-01-10, 23:51
Laffin's Avatar
Laffin Laffin is offline
Senior Member
 
Join Date: Oct 2008
Posts: 32
Default
if the compiler cannot compute the sizeof(short) than its a compiler problem.
as code is simple as
Code:
function main()
{
   printf("%d",sizeof(short));
}
and if your compiler can't handle compiling that routine, its most likely a bad installation of the compiler system. As it should have no problems.
Do as the log suggests, and look into the log file for any further hints as to what the problem is.
Reply With Quote
  #16  
Old 18-01-10, 23:56
mrs's Avatar
mrs mrs is offline
Senior Member
 
Join Date: Jul 2008
P2P
Posts: 17
Default
Here is my config.log.
I'we named it config.log.php because i can't upload it as config.log
Attached Files
File Type: php config.log.php (45.9 KB, 52 views)
Reply With Quote
  #17  
Old 19-01-10, 00:08
Laffin's Avatar
Laffin Laffin is offline
Senior Member
 
Join Date: Oct 2008
Posts: 32
Default
Quote:
/usr/bin/ld: cannot find -lmysqlclient_r
You need to install the mysql client libs, and they should be for the version you are running
Reply With Quote
  #18  
Old 19-01-10, 00:27
mrs's Avatar
mrs mrs is offline
Senior Member
 
Join Date: Jul 2008
P2P
Posts: 17
Default
Quote:
Originally Posted by Laffin View Post
You need to install the mysql client libs, and they should be for the version you are running
I have installed libs and it's working.
Now i'm trying to follow next steps on this turorial.
Maybe i will come with other questions latter.


Thank you
Reply With Quote
  #19  
Old 19-01-10, 01:16
Laffin's Avatar
Laffin Laffin is offline
Senior Member
 
Join Date: Oct 2008
Posts: 32
Default
Well good lucks on your venture :)
Reply With Quote
  #20  
Old 19-01-10, 23:43
mrs's Avatar
mrs mrs is offline
Senior Member
 
Join Date: Jul 2008
P2P
Posts: 17
Default
Quote:
Originally Posted by marius View Post
I have installed libs and it's working.
Now i'm trying to follow next steps on this turorial.
Maybe i will come with other questions latter.


Thank you
Unfortunately i'm back... with another problem :D

Now i'm trying to install it on a centos 5.3 server, not virtual server :D

Now i can run
Code:
./autogen.sh
, but when i run make, i have errors.

What file should i upload here for you to see the errors i have after running make?


Thanks
Reply With Quote
Reply

Tags
debian , gazelle , server , set

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
gazelle on centos 5.3 mrs Gazelle 11 02-08-11 04:36
Looking For a Coder for gazelle thephoenix Gazelle 2 29-05-10 01:29
Installing Webmin and CSF on Debian Lenny Phogo Tutorials 0 26-01-10 13:25
[HELP]Memcache gazelle amnezia Gazelle 1 20-09-09 03:58
Help with gazelle! Viperia Gazelle 4 02-09-09 07:50



All times are GMT +2. The time now is 07:36. vBulletin skin by ForumMonkeys. Powered by vBulletin® Version 3.8.11 Beta 3
Copyright ©2000 - 2018, vBulletin Solutions Inc.